Subscribe to RSS Subscribe to Comments

freesoftwhere.org

What it’s like to use Linux sometimes

A radio play in one act. For two performers.

COMPUTER: Hello, user! Your wireless card isn’t going to work today.
USER: What?? Why not? It worked yesterday. In fact, it worked all last week.
COMPUTER: Tough. Today it won’t.
USER: Well, you can’t trick me. I haven’t touched the configuration since the last time I logged in; everything will be fine.
COMPUTER: No, it won’t. I’ll connect to your AP, but all of your DNS lookups will time out.
USER: Ha! I’ve got you! I’ll change the DNS settings so that the queries are directed to my other box.
COMPUTER: No you won’t. The network settings are hidden.
USER: They aren’t hidden; I’ve done this before, when I set up a DNS server on my other box and my router to handle local hostnames.
COMPUTER: That doesn’t matter. Every six months, all of the system admin tools are changed and replaced by your distribution. Whatever you learned last time is of no value.
USER: Pfft. I’ll still find it.
COMPUTER: You can try, but the names of the applications have changed too. Plus, the desktop environment you use has been revised twice, so none of the system admin apps are available in any menus.
USER: So? I’ll search for them. I guess that’s what I’m supposed to do.
COMPUTER: You can try, but you won’t guess the names. And the descriptions of the apps are not indexed by the search tool back-end.
USER: Now you’re just lying; I’ve read in blog post after blog post that the search framework indexes the descriptions of the applications.  I think I even heard it in a talk.
COMPUTER: Knock yourself out, then.
USER: Dammit! What the hell did they describe this thing as?? I’ve tried “network,” “connection,” and “settings” — all it finds is a VPN setup tool and something to configure Twitter accounts! I’m running out of synonyms.
COMPUTER: Don’t feel bad; the app you’re thinking of probably isn’t installed by default anyway.
USER: That’s absurd; of course the system admin apps are installed…. Right? And if it’s not, I’ll install it.
COMPUTER: From where?
USER: Gar.  Wait a second; I don’t need to mess with that anyway — I’ll edit /etc/resolv.conf
COMPUTER: Won’t help; you’re using DHCP.
USER: Well, I’ll just edit the DHCP settings…
COMPUTER: In what, the network admin tool?
USER: Dammit! No, no; can’t get out of control — I’ll edit the DHCP configuration files by hand. Let’s see … there appear to be two of them, in /etc/dhcp/ and /etc/dhcp3/ … I wonder which one is the right one?
COMPUTER: You should probably look that up.
USER: Ah; good idea. Let’s open Googl — Dammit!! Not funny!!
COMPUTER: Okay, that was a low blow. But you were getting ahead of yourself.
USER: Well, it backfired anyway. I just realized I don’t *need* DNS at all; I can look up all of the IP addresses I want to visit on one of my other PCs, then enter them by number in the location bar.
COMPUTER: Actually, you can’t. All this time, you assumed we were having a DNS problem, but in fact all of your traffic is going to time out, even if you enter the addresses by number.
USER: That’s ludicrous. Clearly that indicates a connectivity problem; I’ll log in to the router.
COMPUTER: Heh heh; good luck.
USER: Who needs luck? It’s six feet away, and I’m already connected to it. I can type in 192.168.1.1 and bring up the admin interface … any moment now … oh come on, hurry up … Dammit!!! What the hell is going on here?
COMPUTER: I can’t divulge that.
USER: Well it must be a hardware problem. Everything has been working fine for weeks, I haven’t touched the software or altered the configuration, and it isn’t on the router’s side.
COMPUTER: That’s a possibility; you should check to see if there are known issues related to this.
USER: Okay; I will, from by other box…. Well, my distribution has nothing similar sounding in the issue tracker, and everyone on the forum says it’s probably the DE at fault…. Although everyone on the DE mailing list says my distro changes some of the defaults, so they don’t support it. Unless it’s the browser…. But the browser forum says I’m eleven versions out of date, since they now issue “mandatory” updates every three days; what I’m running through my distro is “unsupported.” And I could download an update and install it manually over the distribution’s repository package, but then they wouldn’t support me if it turned out not to be the browser’s fault … plus I can’t download it anyway, since I have no connectivity. But I’m not sure that helps anyway. Clearly something was working fine yesterday and isn’t today. If it’s not hardware there’s very little else it could be. Apparently everybody in the kernel driver community hates this WiFi chip because of some dust-up in 2007, but I can’t really apply what they say about it on the mailing lists, because they’re all running a development kernel on some distribution that I think they seem to have written from scratch. But it doesn’t matter: it’s hardware; I can verify that by booting into OS X on the other partition.
[ -REBOOT- ]
COMPUTER: Welcome to OS X; everything is running normally.
USER: Dammit. Maybe if I just use OS X for a few days, the problem will go away again all on it’s own.

Based on FluidityTheme Redesigned by Kaushal Sheth